Incompatible with Firefox 14 Rated 5 out of 5 stars

Pentadactyl no longer runs on Firefox 14..T.T, oh! no!

This review is for a previous version of the add-on (1.0rc1).