Rated 5 out of 5 stars

The v0.6.5 that you can find at the author's website works perfectly with Firefox 4.0, you have just to enable the extensions bar (no need to status-4-evar extension).