I wonder why there is no remove/delete button in the option Rated 4 out of 5 stars

Look at the screen shot image 7 of 7. There are "Add" and "Default Order" button...
But it seems to me that "Edit" and "Remove/Delete" are missing.

This review is for a previous version of the add-on (5.0.3.1-signed). 

The context menu trouble is now solved with SeaMonkey 2.1 Rated 5 out of 5 stars

I had a trouble before with SeaMonkey 2.0 that context menu didn't respond...but now it's solved by updating SeaMonkey to latest stable 2.1 !

This review is for a previous version of the add-on (5.0.3.1-signed). 

5.0.2 still has a problem with SeaMonkey Rated 4 out of 5 stars

Only the trouble is context menu on a link, used with SeaMonkey 2.0.13 .
Even when all the other add-ons are disabled, the same problem still happens. ;-(
No problem with other features.
Keep cool. SeaMonkey users aren't so many as Firefox :-)

This review is for a previous version of the add-on (5.0.2.1-signed). 

5.0.1 still has problems... Rated 4 out of 5 stars

1. Context menu clicked over a link doesn't work...
2. Is Version 5.0.1 a special SeaMonkey build? AMO now interprets the developer to quit support FF (Try AMO Search for FF Add-ons, looking for Open With).
BTW, the option button now works fine! (Thanx)
==== March 31, 2011 ====
I tried re-install (cleaning configs like "extensions.openwith.*")... but the same problem still happens.
As you mentioned it, I use many add-ons which also use context menu...It's possible conflicting with other add-ons. But context menu on a tab or a web page NOT hovering over a link works properly. Peculiar...

This review is for a previous version of the add-on (5.0.1.1-signed). 

1. Working okay for me. Have you got something else installed which changes the context menu?
2. Aaargh noooo! I hadn't considered that AMO might do that. :-(

Option Freezes on SeaMonkey 2.0.13 Win Rated 4 out of 5 stars

After upgrading Open With to 5.0 , clicking the option button in the add-on manager freeze itself, though browser tabs are still alive.This does not happen with Firefox 4.0 and 3.6.15. Only with SeaMokey ;-((I don't know whether this problem is reproduced on Mac or Linux.)

This review is for a previous version of the add-on (5.0.1-signed). 

Odd. I'll look into it.
[edit] ... aaand that would be due to me breaking it. Sorry, fix on the way.