Concern with "No need to modify" comments by max32x Rated 5 out of 5 stars

Although the method for making "Open In RegEdit" work with Firefox 4 described by max32x below will work, it will also turn off version checking for ALL other add-ons in Firefox 4. Personally, I'd rather selectively turn off version checking for EACH add-on that doesn't work with the latest version of Firefox so I have some semblance of control. The method I suggested (repeated below), will only allow THIS add-on to work in all versions of Firefox 4.

Simple fix for making "Open In RegEdit" work with Firefox 4.0 and beyond
This has been tested and proven to work with Firefox 4.0 running on Windows XP SP3 32-bit and on Windows 7 SP1 64-bit. This change should allow it to work through Firefox version 5.0.

1. Search for directory (folder) "openinregedit@firefox" (without the quotes). If you find more than one, do the following steps for each one found.

2. Within the "openinregedit@firefox" directory, find file "install.rdf" and open it using Notepad.

3. Change line
<em:maxVersion>3.2a1pre</em:maxVersion>
to
<em:maxVersion>5.0</em:maxVersion>

4. Close Notepad answering "Yes" to the "Do you want to save the changes?" question.

"Open In RegEdit" will now work properly in Firefox 4.0.

Stu Berg

Rated 5 out of 5 stars

Simple fix for making "Open In RegEdit" work with Firefox 4.0 and beyond

This has been tested and proven to work with Firefox 4.0 running on Windows XP SP3 32-bit and on Windows 7 SP1 64-bit. This change should allow it to work through Firefox version 5.0.

1. Search for directory (folder) "openinregedit@firefox" (without the quotes). If you find more than one, do the following steps for each one found.

2. Within the "openinregedit@firefox" directory, find file "install.rdf" and open it using Notepad.

3. Change line
<em:maxVersion>3.2a1pre</em:maxVersion>
to
<em:maxVersion>5.0</em:maxVersion>

4. Close Notepad answering "Yes" to the "Do you want to save the changes?" question.

"Open In RegEdit" will now work properly in Firefox 4.0.

Stu Berg

Stu Berg Rated 5 out of 5 stars

Since the "Visit the support site" link on this page takes me back to this page, I'm assuming it's okay to break the rule about not using the Review function for posting bug reports.

It would be WONDERFUL if this add-on were updated to work with Firefox 4. I use it frequently and know many others do as well. We would be VERY appreciative if you would update this great add-on. If you have no plans for updating, please let us know that though these reviews. Then we can pursue other possible ways to perform this function.
Thanks,
Stu