Can't Install Rated 3 out of 5 stars

I can't seem to install the add-on because of a failed hash check. Will try again later, though. FF 3 is too annoying not to.

Thank you for putting in the hard, tedious work of developing workarounds for Mozilla's mistakes. If it weren't for developers like you, I'd just never upgrade.

This review is for a previous version of the add-on (1.9).