FF3.5.1 and v1.6.2 are not compatible Rated 5 out of 5 stars

Sadly, this great extension (v1.6.2) doesn't work with FF 3.5.1. I have the same problems as all previous comments. Middle click will not open a new tab for the selected URL. Did I miss the solution? v1.6.1 is no longer available for download and I don't have a copy of it. I post this here because the 'support section' link doesn't work.

This review is for a previous version of the add-on (1.6.2).  This user has other reviews of this add-on.