still works with FF 8 Rated 5 out of 5 stars

just change the max version line in the install.rdf inside the xpi package

This review is for a previous version of the add-on (3.0.0.16).