OK! That works for me. Rated 5 out of 5 stars

This is such a elegant app, although I'm speaking strictly as an end-user.

And with no support for Firefox 4.0 I have yet another reason to wonder why there's an FF 8 when 3.6 works so well.