Rated 5 out of 5 stars

DEFINITELY not updating to FF6 until there's full compatibility...
An absolute must have.

This review is for a previous version of the add-on (1.35.1-signed.1-signed).