Doesn't work... Rated 2 out of 5 stars

This isn't up to date. I attempted to install ignoring the version check but still wasn't able to install because I have ff 3.5.5, I hope that this is updated soon. It sounds like a good idea.