Rated 1 out of 5 stars

Having problems using this addon for firefox, this might still be because of the version support. But im using 4.0 and not 4.0.1.