Nice and working in TB 3.0.5 Rated 4 out of 5 stars

I like its functionalities.

(Use the following information at your own risk!)
It works with TB 3.0.5, but to install it you have to modify "install.rdf" inside the XPI package (ZIP file) so that maxVersion for Mozilla Thunderbird is "3.0.*".
If you want to test it in TB 3.1 use "3.1.*".