Not working with FF3.6 Rated 3 out of 5 stars

Does not seem compatible with 3.6. Getting a message stating incompatibility. Even with v1.4.3.