Not sympatico with FF3 :-( Rated 3 out of 5 stars

I love the look of this, but I sooo want it to be compatible with FF3, to which I just upgraded. I love Star Trek AND Firefox, so I felt disappointed at not being able to download it yet, so, for now, I'm going to have to give it 3 stars.

This review is for a previous version of the add-on (1.8.1).