Rated 5 out of 5 stars

please find a new file here.
Your old version 2.2 is highly compatible with firefox 4.
Here is the file http://goo.gl/jCidB

This review is for a previous version of the add-on (3.0t3). 

Rated 1 out of 5 stars

Add on suddenly gave up? NOt working I got it from developer's page. I was working fine but now not working

This review is for a previous version of the add-on (3.0t3).