Rated 3 out of 5 stars

Incompatible with Firefox 18 on linux 64bit
Update: I download from lastpass.com and it worked. Don't know why~, But it surely is a great addon.

This review is for a previous version of the add-on (2.0.0).