Still new firefox users can use this. Rated 5 out of 5 stars

If you have FF3 do not worry use "Extesions.checkcompatibility" configuration for firefox
Link to read more:
http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox