Seems to work on Firefox 4.0 Rated 5 out of 5 stars

I am tying this review with jV enabled in Firefox 4.0 and it seems to work just fine. I used the Add-on Compatibility Reporter addon to enable jV and try it out, but you should be able to change the install.rdf to bump up the max version to 4.0.