Perfect, but will it get ready for FF 57+ ? Rated 5 out of 5 stars

I like your work very much. In the past I was using another tool but it is not supported any longer (Babylon). I moved to ImTranslator and it works great, the comparison tool as well. According to my historical experiences I would like to know: will you get ready for Firefox 57+. When do you plan to be ready? Thx for any information.

This review is for a previous version of the add-on (10.52). 

ImTranslator for FF 57+

ImTranslator version compatible for FF 57+ is under development, and will be available soon.
In the meantime, you can try our Translation Comparison multiprocess extension : https://addons.mozilla.org/en-US/firefox/addon/translation-comparison/