Image2Icon - Resize Image and/or Get Data URI Version History

11 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 0.29.1-signed.1-signed 182.9 KiB Works with Firefox 19.0 and later

Fixed the issue caused by FF retiring faviconService

Version 0.28.1-signed.1-signed 182.9 KiB Works with Firefox 19.0 and later

No code change. Repacked with SDK 1.14 to make addon work for FF22

Version 0.27.1-signed.1-signed 180.2 KiB Works with Firefox 18.0 and later

No code change, just updated the addon with SDK 1.13.2 to suit newer browser versions as AMO requested.

Version 0.26.1-signed.1-signed 162.0 KiB Works with Firefox 14.0 and later

No code change at all. Repacked with SDK1.9 to get rid of annoying warnings in Error Console due to outdated SDK used by the previous Img2Ico version.

Version 0.25.1-signed.1-signed 156.8 KiB Works with Firefox 9.0 and later

Very important update:
1. Now packed with Addon SDK 1.6.1, which is leaner and does not have the memory leaks of Addon SDK 1.0, which I had to use to pack the previous version of I2I.
2. To make I2I work with SDK 1.6.1, a lot of code was changed. And now everything works well.
3. Fixed a bug for viewing site's favicon (didn't work for iframes before).

Version 0.24.1-signed.1-signed 165.0 KiB Works with Firefox 4.0b7 and later

Version 0.22.1-signed.1-signed 269.3 KiB Works with Firefox 4.0b7 and later

This release is same as 0.2 but is necessary to override Jetpack's auto-SDK-update feature (which introduced a bug).

Version 0.2.2.1-signed.1-signed 170.9 KiB Works with Firefox 4.0b7 and later

Version 0.2.sdk.1.0.1-signed.1-signed 254.3 KiB Works with Firefox 4.0b7 and later

Version 0.2.1-signed.1-signed 258.8 KiB Works with Firefox 4.0b7 and later

Added ability to deal with images in image-only tabs. This in effect allowed image->icon conversion for all local images, background images etc.

Version 0.1.1-signed.1-signed 250.4 KiB Works with Firefox 4.0b7 and later