Rated 3 out of 5 stars

Please update this to work with Firefox 3.1b3pre. Thanks.

This review is for a previous version of the add-on (1.1.6). 

Update

Hi geeknik,
I have updated the supported version range to include Firefox 3.1 betas. Please report back if the extension works as-is or if I need to install a 3.1b test environment to update against.

Thanks!