Rated 5 out of 5 stars

Great tool!

Ben, thanks for updating for FF4!

This review is for a previous version of the add-on (0.6.9.1-signed). 

Update for FF4 needed Rated 5 out of 5 stars

This is an extremely useful add-on and it is the only add-on that prevents me from upgrading to FF4. It tried forcing it to work with FF4 by tweaking the MaxVersion, but it didn't work => all the toolbar buttons show up when you hover over an image but nothing happens when you click them.

Ben please update for FF4!

I saw that Ben said that an update is coming soon back in Jan 2011. Hopefully it is really coming soon

This review is for a previous version of the add-on (0.6.8).