Rated 5 out of 5 stars

not compatible with recent firefox 3.6 nightly build anymore. please consider update it.

This review is for a previous version of the add-on (1.5.20090525).