Love this addin Rated 5 out of 5 stars

I've always used this addon extensively, since most companies favor IE. I'm running FF 17.0 and it seems to work fine; not sure why other people are seeing problems. Perhaps there's an issue with another addon?

This review is for a previous version of the add-on (4.1.3.1.1-signed).