Rated 1 out of 5 stars

Not possible to install because of this error:

Hash file not valid (maybe download corrupted) error -261

This review is for a previous version of the add-on (2.3.9.1).