Rated 2 out of 5 stars

This add-on is great when it works, but does not keep up with Firefox updates. Support for HTML5 also seems to be sketchy. I would also suggest the developer publish just one version that works with all previously released versions of Firefox instead of a different version for each.

This review is for a previous version of the add-on (0.9.1.1). 

Frustration

Sure, I understand your frustration. As writer of the extension, I have the same one. Before F F4.0 the extension was compatible with all previous FF version.
Then Firefox decided to break binary compatbility with XPCOM in each version for very bad reasons. So, there is no easy solution to write a extension with binary files anymore in FF except with a full rewrite... And the extension code is huge.