fatal error Rated 5 out of 5 stars

on FF7
FATAL ERROR : The dynamic C library contained in the extension file could not be found.

This review is for a previous version of the add-on (0.9.1.0). 

Add-on bug

You need version 0.911.
To make the story short, there is a bug in addons.mozilla.org (https://bugzilla.mozilla.org/show_bug.cgi?id=689733)
that detect that the version is compatible with FF7.0 automatically. But it is not.
0.911 is submitted for review since last week.

Solution in the meanwhile: get the version 0.911 here: http://users.skynet.be/mgueury/mozilla/download_090.html