Homeland Security Threat Level Version History

4 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 0.53 29.7 kB Works with Firefox 1.0 - 3.0.*

This update is compatible with Firefox 3.

Version 0.52 29.7 kB Works with Firefox 1.0 - 3.0a1

Version Bump: Allows compatibility with Firefox version 3.0a1.

Version 0.51 29.7 kB Works with Firefox 0.7 - 1.5.0.*

Added support for Firefox 1.6a1.

Version 0.5 29.7 kB Works with Firefox 0.7 - 1.5.0.*