Rated 5 out of 5 stars

very good, I used it before update firefox.
Should be compatible with 3.6 FFx
Usava ele antes de atualizar pro 3.6
Deveria ter para FFx 3.6
=/