Update, Please. Rated 5 out of 5 stars

Please update this for Firefox 6.0!
I really want to use this! Thank you. :)