Rated 3 out of 5 stars

One problem I see with it is it injects into the page and won't work if you have No Script blocking the site your trying to translate. If this can be fixed, it'll make me more happy to use it.

Rated 5 out of 5 stars

Add support for firefox 4

This review is for a previous version of the add-on (1.0.3). 

gTranslator兼容FF4.0方法(感谢Murat) Rated 5 out of 5 stars

感谢Murat的方法,本人测试通过。为了方便国人,我又做个汉语的修改说明(Murat用得好像是土耳其语):用WinRAR打开xpi下载地址:https://addons.mozilla.org/firefox/downloads/latest/76233/addon-76233-latest.xpi(看网址大家应该知道就是本网站的,不会有病毒的,FireFox点安装的话是直接安,根本不知道它把xpi文件放哪里了)打开后把“install.rdf”解压出来,用记事本打开它。把<em:maxVersion>3.6.*</em:maxVersion>中的“3.6”改成“4.0”就好了。再把文件放回压缩包,替换原文件。再把xpi文件直接往FF里一拖就好了,可以安装了。测试完全兼容,没有问题。

This review is for a previous version of the add-on (1.0.3). 

Firefox v4++ uyumsuzluk sorunu çözümü Rated 5 out of 5 stars

Firefox 4.0 uyumsuzluk sorununu çözmek için;
*.xpi dosyasını bir arşiv yönetici ile açınız, (winrar, 7zip) arşiv içerisindeki "install.rdf" dosyasınını bir metin düzenyeyici yardımıyla açtıktan sonra
" <em:maxVersion>3.6.*</em:maxVersion>"
satırındaki "3.6." değerini "4.0." veya daha fazlası bir değerle değiştirip arşivin içerisine kaydediniz.

This review is for a previous version of the add-on (1.0.3). 

Thank you Johng Rated 5 out of 5 stars

i wait the update for FF4,but not.
thank you, Johng.The address can down new one.
Thank you.

This review is for a previous version of the add-on (1.0.3). 

Rated 1 out of 5 stars

yhh pls before 2014

This review is for a previous version of the add-on (1.0.3).  This user has a previous review of this add-on.

Really need it for Firefox 4 Rated 5 out of 5 stars

Please make an update for FF4. this is VERY useful addon.
thank you.

This review is for a previous version of the add-on (1.0.3). 

Rated 5 out of 5 stars

hey guys, I found a counterpart for this add-on !!
"Google Dictionary and Google Translate 2.3
by Zen"
The latter one I mentioned above can totally substitute gTranslator. Have a try guys!

This review is for a previous version of the add-on (1.0.3).  This user has a previous review of this add-on.

Please Update for firefox 4 Rated 5 out of 5 stars

Please Update for firefox 4

This review is for a previous version of the add-on (1.0.3). 

update dor FF4 please Rated 5 out of 5 stars

Yes pleeaaasssseeeeeee.......
I'm still use FF 3.6 because I can't get this usefull add on for FF4!!
love this add on so muuuuccchhhh....

This review is for a previous version of the add-on (1.0.3). 

Rated 5 out of 5 stars

for fierefox 4 can be forced to register in file the file C: \ Documents and Settings \ CURENTUSER \ Application Data \ Mozilla \ Firefox \ Profiles \ CURENT_PROF.default \ extensions \ jyboy.yy @ gmail.com \ install.rdf string <em:maxVersion> 3.6 .* </ em: maxVersion> to <em:maxVersion> 4.6 .* </ em: maxVersion> and press Ctrl + \ in the menu Firefoh form

This review is for a previous version of the add-on (1.0.3). 

Rated 5 out of 5 stars

For firefox 4 please!

This review is for a previous version of the add-on (1.0.3).  This user has a previous review of this add-on.

Rated 5 out of 5 stars

This is a very nice addons for firefox 3.X. But many of firefox 4 want it too. Please update it for us. Thank you!

This review is for a previous version of the add-on (1.0.3). 

Rated 5 out of 5 stars

for firefox 4 please!

This review is for a previous version of the add-on (1.0.3). 

Rated 5 out of 5 stars

>天下无雪
thanks you!!

This review is for a previous version of the add-on (1.0.3).  This user has a previous review of this add-on.

Rated 5 out of 5 stars

Hi, guys, you can modify the max version of the gTranslator, it works fine on my FF4.0rc2Here is the modification link: http://www.filefactory.com/file/ca2fe45/n/gTranslator{1.0.3}.xpi or http://www.rayfile.com/files/99363ce6-51f0-11e0-b1be-0015c55db73d/

This review is for a previous version of the add-on (1.0.3). 

Rated 5 out of 5 stars

Please update for firefox 4 .

This review is for a previous version of the add-on (1.0.3). 

Fantastic! Rated 4 out of 5 stars

Its awesome addon, works fine. But please, update to firefox 4! Do that and i will give 5 stars!

This review is for a previous version of the add-on (1.0.3). 

Rated 5 out of 5 stars

Great addon . Please update for firefox 4 .

This review is for a previous version of the add-on (1.0.3).  This user has a previous review of this add-on.

Rated 5 out of 5 stars

A fantastic add-on. As much as I like Google Chrome, I still can't bring myself to switch over entirely. Firefox is just too damn useful and diverse to give up. I've tried a few other translators before this one, and this is the only add-on that did exactly what I wanted quickly, fast, and efficiently. Thank you very much for this!

This review is for a previous version of the add-on (1.0.3).