Rated 5 out of 5 stars

Don't know what is wrong with some people, Greasemonkey works perfectly with Firefox 3.0.x, 3.5.x and 3.7a1pre.

This review is for a previous version of the add-on (0.8.20090920.2).