Not Working Rated 1 out of 5 stars

Not working in Firefox 3.5b4 using oGame v0.84

An excellent tool if you can get it to work, hopefully whatever is wrong will be fixed soon.

This review is for a previous version of the add-on (2.2.1). 

firefox beta

this addon is not designed to be run with firefox 3.5 . Yo can however override cmopatibility if you know how. No guarantee from our side. Also: Noone reads support requests here. Ways to contact us that really work see here: http://en.wiki.galaxytool.eu/index.php/Contact