My favourite add on Rated 5 out of 5 stars

Hi Michael, I love Foxscape - thanks very much for your hard work. I've noticed that Foxscape 5.04 isn't compatible with Firefox 16. It would make me very happy if you're able to update it - my computer isn't the same without it!

This review is for a previous version of the add-on (5.04).  This user has other reviews of this add-on.

Done!

Thanks for your support, enjoy.