I miss it on FF5 Rated 5 out of 5 stars

I upgraded to FF5 a couple of days ago and Foxclocks was working fine. Then this morning I noticed it is gone. I opened my Add-ons info and found a message that Foxclocks is now incompatible with FF5. I miss it and I hope it is fixed soon!

This review is for a previous version of the add-on (2.7.82.1-signed).  This user has other reviews of this add-on.