Rated 5 out of 5 stars

no longer works with 3.7a2pre don't forces sites to https for me any longer :( now im unsecure

This review is for a previous version of the add-on (2.0).