Rated 1 out of 5 stars

compatible for firefox 4.0 beta 9 +, please

This review is for a previous version of the add-on (2.1.10).