Needs update Rated 3 out of 5 stars

Hoping to see an update soon... seems like a great tool, but can't get it to work on FF3.5 (even after forcing installation)