Rated 2 out of 5 stars

-2: Not worked when JavaScript disabled (so, when I trying increase security by disabling JS, your extension decrease my security by enabling Flash ads).
-1: Latest update not installed on FF 3.6.17 because "download error" (but other extensions updated without problems). The error message:
-------------
Firefox could not install the file at
http://releases.mozilla.org/pub/mozilla.org/addons/433/flashblock-1.5.15-fx.xpi
because: Download error
-228
----------------

This review is for a previous version of the add-on (1.5.15.1.1-signed).  This user has a previous review of this add-on.