Rated 5 out of 5 stars

I miss this add-on. I just came to think about it recently and wanted to install it, only to find it's not compatible with the latest version of Firefox, 8.0.1. Please update!