Rated 5 out of 5 stars

Please keep working on this to make it compatible with 4.0+, you have so many lovers of this app I don't see why not!