Rated 1 out of 5 stars

guys just read above
"
Firefox 4.0 support: I won't support Firefox 4.0 or later. If you're a developer and want to add Firefox 4.0 support yourself, please contact me in the forum thread linked above. Otherwise please try the Status-4-Evar extension from https://addons.mozilla.org/addon/status-4-evar/ instead."