Rated 5 out of 5 stars

Using the add-on compatibility reporter to check, as far as I can tell it still works with the latest version of firefox as of this comment.