Does not work with Firefox 8 Rated 5 out of 5 stars

Not compatible with Firefox 8. When will this be updated?

This review is for a previous version of the add-on (1.3).