Firefox 3 could not install firebug 1.2 Rated 1 out of 5 stars

Here is the error message ff threw

Firefox could not install the file at

https://addons.mozilla.org/en-US/firefox/downloads/file/30423/firebug-1.2.0b3-fx.xpi

because: Unexpected installation error
Review the Error Console log for more details.
-203

This review is for a previous version of the add-on (1.2.0b3).