Firefox update problem Rated 5 out of 5 stars

I recently update my ubuntu to 8.4 and got Firefox v. 3.0b5. This version is incompatible with firebug :(

This review is for a previous version of the add-on (1.05).