Rated 5 out of 5 stars

Fantastic add-on. An absolute must!!! However - I can't grab 1.5.3 - says FF 3.5 or higher - yet I'm on 3.5.7 .

This review is for a previous version of the add-on (1.5.3).