Rated 5 out of 5 stars

Please, make it compatible with Firefox 4.

This review is for a previous version of the add-on (1.14.8). 

Firefox 4

You can download the version compatible with Firefox 4 from my site: http://www.sogame.cat/eldumper/