If you're having trouble with 1.5.3... Rated 5 out of 5 stars

If you're having trouble with version 1.5.3., then you might actually have 1.5.2. Take a look and see. All I know is that well before 5 a.m. Central Time today, 1.5.3. was available, but Firefox notified me about 1.5.2 instead because 1.5.3. was not on the main page yet (I think this means that 1.5.3. wasn't "approved" yet). I found it when I tried to revert back to 1.5.1. (1.5.2. was giving me both Classic and New Styles simultaneously, and Slim Mode did not work), by going to the "See All Versions" page.

So, perhaps you updated to 1.5.2, then came here to write a review assuming that it's 1.5.3. because that's what's on the main page now (because after all, you think that you just got the latest version). Does that make any sense? I think that this is a good lesson for us to be absolutely certain that we know which version we're referring to in our reviews.

This review is for a previous version of the add-on (1.5.3).