Rated 3 out of 5 stars

last release broke compatibility with pentadactyl (ff4.0b11)

This review is for a previous version of the add-on (1.5.7.1-signed).